[Lazarus] Installation of 1.8 RC4 fails.

Donald Ziesig donald at ziesig.org
Fri Oct 13 02:39:44 CEST 2017

On 10/12/2017 07:52 PM, Mattias Gaertner via Lazarus wrote:
> On Thu, 12 Oct 2017 18:21:28 -0400
> Donald Ziesig via Lazarus <lazarus at lists.lazarus-ide.org> wrote:
>> Hi All!
>> I downloaded the three .deb files for 18 RC-4 and tried to install them
>> (the checksums are valid).
>> The two fpc 3.0.4 files said that they installed correctly, but all I
>> can find are versions 3.0.0 and 3.0.2 anywhere on my hdd.
> This makes no sense.
> How did you install the two deb files?
>> I tried to install the ide but it complained that it was missing fpc 3.0.4.
>> This is on Linux Mint 18.1 (Sarah).
>> Does anyone have any suggestions?
> Mattias

Hi Mattias,

I've done this many times over on many machines (all Debian derivatives) 
in the past and never had a problem like this.

I validated the checksums on all three files.

Then I double clicked on /home/donz/Downloads/fpc_3.0.4-rc1_amd64.deb to 
activate "Package Installer".  Then clicked "Install Package".  Result 
seems to be success (but with no sign of the compiler).  What is the 
standard path for the installation?

Then same procedure on 
/home/donz/Downloads/fpc-src_3.0.4-rc1_amd64.deb.  Result also seems to 
be success (but again no sign of the sources).

Double click on 
/home/donz/Downloads/lazarus-project_1.8.0RC4-0_amd64.deb.  Before I can 
do anything else:

Error:  Dependency is not satisfiable: fpc(=3.0.4) | fp-compiler(=3.0.4).

I am about to remove all vestiges of Lazarus and FPC from my system and 
start over, but I really would like to know what is going wrong before I 
do. :'(



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20171012/8342777e/attachment.html>

More information about the Lazarus mailing list