[Lazarus] fpcres not found with custom FPC 2.6.4 installation on Ubuntu

Krzysztof dibo20 at wp.pl
Tue Jan 30 00:19:22 CET 2018


I have fresh and clean Ubuntu OS (actually KDE Neon) and want to
install Lazarus and FPC not with .deb packages as I used to do from
many years, but in custom home dir (nothing in /bin or /usr/bin)
because I want to have FPC 2.6.4 and FPC 3.0.4 living together
separated + Lazarus 1.8 compiled and using right FPC version.
So I downloaded FPC binaries + source and Lazarus 1.8 source. At first
started with FPC 2.6.4. Extracted everything into:

/home/<username>/programowanie/fpc2/fpc <-- binaries
/home/<username>/programowanie/fpc2/fpc-src <-- FPC source
/home/<username>/programowanie/Lazarus_1_8_FPC2 <-- Lazarus source

The "/home/<username>/programowanie/fpc2/fpc" dir is a result of
"install.sh" from fpc-2.6.4.x86_64-linux.tar. I ran it without "sudo"
so I'm sure that nothing is put in "/usr/bin" or "/bin" because it
require root permission. File /home/<username>/.fpc.cfg is created
correctly with all paths pointing to
"/home/<username>/programowanie/fpc2/fpc". Everything looks fine. Now
I have "mylazbuild.sh" build script in "Lazarus_1_8_FPC2" dir with

 #!/usr/bin/env bash
make clean
make all PP=/home/<username>/programowanie/fpc2/fpc/lib/fpc/2.6.4/ppcx64

When run it (without sudo of course), it is compiling for a long while
(promises good config), but at the end getting:

lazbuild.lpr(1872,1) Error: (9021) resource compiler "fpcres" not
found, switching to external mode

Any idea what is wrong? Do I have specify something in "export
PATH=...."? Tried even make symlink to the ".../fpc2/fpc/bin/fpcres"
in "/usr/locale/bin" or "/usr/bin" or "/bin" but it didn't help


More information about the Lazarus mailing list