[Lazarus] Installed lazarus-ide in Ubuntu18, cannot install package

Bo Berglund bo.berglund at gmail.com
Tue Oct 23 19:42:42 CEST 2018

I have decided to try out the version of Lazarus that can be installed
via apt on a brand new installation of Ubuntu 18.04 wit MATE desktop.
So I used this command:
sudo apt install lazarus-ide

This completed without errors and the Applications/Development menu
contains Lazarus 1.8.2, which uses FPC 3.0.4

So far so good, now I wanted to open my console program project that
works on Windows and build it for Linux. Since it uses INDY10 I needed
OnLinePackageManager to install IndyLaz into Lazarus.

But now I get into trouble!
After I selected OLPM in Install/Uninstall Packages and set it for
installation I clicked "Save and rebuild IDE" and it started doing
things but then it stopped with an error:

lazarus.pp(1,1) Fatal: Cannot find lazcontroldsgn used by Lazarus.

What can I do now? I already have tried to install FPC 3.0.4 with
Lazarus 1.8.4 from svn checked out sources but it failed because of a
linking problem after 1m30s of make all activity for FPC.
So that is why I tried the apt install route.

Clearly installing via apt install should get a working system, but it
seems not to do that.

Bo Berglund
Developer in Sweden

More information about the Lazarus mailing list