[Lazarus] Built console app on Linux, but won't run on another Linux machine

Sven Barth pascaldragon at googlemail.com
Sun Oct 28 00:49:50 CEST 2018

Bo Berglund via Lazarus <lazarus at lists.lazarus-ide.org> schrieb am So., 28.
Okt. 2018, 00:44:

> >> Not so simple in Lazarus until I saw I could install indylaz.
> >> Has worked fine for GUI applications so far....
> >
> >Yes, Indy apparently suits best for GUI apps.
> >You can of course set the search path of your Lazarus project to point
> >to Indy source directories.
> >That is not recommended normally but this is a special case.
> >If Indy Lazarus port was well designed, it would separate the GUI and
> >non-GUI parts to their own packages.
> >
> I found the location of the indylaz package files in:
> ~/.lazarus1.8.4/onlinepackagemanager/packages/Indy10/
> Here are the 3 dirs I need, Core, Protocols and System.
> So I adding these into the Compiler/Path/OtherUnitFiles setting in
> Project Options lusing the selector button
> ../../../.lazarus1.8.4/onlinepackagemanager/packages/Indy10/Core
> ../../../.lazarus1.8.4/onlinepackagemanager/packages/Indy10/System
> ../../../.lazarus1.8.4/onlinepackagemanager/packages/Indy10/Protocols
> And I also removed the indylaz package from the project dependencies.
> But when I tried to build the project it complained that it could not
> find Interfaces, so I remembered that this is supplied by LCL, so I
> tried adding LCL back to the project required packages.
> Then the project built OK.

That something is pulling in unit Interfaces is proof that something tries
to use GUI units. So either find out what unit that is (it could either be
one of yours or maybe an Indy one) or try to set the LCLWidgetType to NoGUI.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20181028/0e7e9741/attachment.html>

More information about the Lazarus mailing list