[Lazarus] Can't install LazSerial 0.2 in Lazarus 2.0 under Raspbian

Pedro Restrepo restrepopj at gmail.com
Sat Feb 23 00:57:22 CET 2019


I am running LazSerial v0.2 on Raspbian. I ran into the same problems you
did, but finally got it installed. I can't remember exactly what I did, but
in my source code I commented out lines 251..263. I can send you the source
and the compiled versions. It has been working flawlessly for about 4 months


On Fri, Feb 22, 2019 at 8:34 AM Joe via lazarus <
lazarus at lists.lazarus-ide.org> wrote:

> Hi,
> the package can't be compiled. Reason: The file "lazsynaser.pas" in
> lines 252..262 references undefined constants. They should be defined in
> file 'termios.inc'. In other operating systems and/or Lazarus versions
> they are, but not in Lazarus 2.0 under Raspbian Stretch, Nov 2018 edition.
> As a quick and very dirty intermediate fix I replaced the constants in
> these lines with literal expressions. This worked, but of course that's
> no tidy solution.
> I could not get the mail address of 'JurassicPork', the author of
> LazSerial. Does someone know this address?
> Regards --  Joe
> --
> _______________________________________________
> lazarus mailing list
> lazarus at lists.lazarus-ide.org
> https://lists.lazarus-ide.org/listinfo/lazarus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20190222/9a8f580c/attachment.html>

More information about the lazarus mailing list