[Lazarus] New application - Mac OSX Problems

Anthony Walter sysrpl at gmail.com
Sat Jun 1 19:01:18 CEST 2019

I wrote a new application for both Windows and Linux:


It was a favor for a less than computer literate friend who couldn't open a
terminal and run rsync backing up of their video work to two redundant
network drives.

The program works fine on both my Linux and Mac computers, but on his Mac
laptop there is an issue. The rsync seems to run, but is not actually
copying files. I've looked at rsync manually on his computer from the
terminal and it works. When I run the exact same command from my Lazarus
program (inside a thread) the thread completes as if everything worked, but
no files are actually copied through rsync.

Could someone take a gander at this little bit of code and possible
decipher why it's failing on his Mac, but not on my Mac or Linux computer?


The thread is created passing it to list of strings, the source folders,
and the dest folders. The thread then creates private copies of those items
as FSource and FDest and calls inherited Create(False).

The execute procedure FreeOnTerminates, then loops through each source,
rsyncing it to each dest location.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20190601/3d705686/attachment.html>

More information about the lazarus mailing list