[Lazarus] Lazarus 2.0 doesn't compile LabJack wrapper

Mattias Gaertner nc-gaertnma at netcologne.de
Thu Mar 7 08:33:03 CET 2019


On Thu, 7 Mar 2019 00:53:32 +0100
Joe via lazarus <lazarus at lists.lazarus-ide.org> wrote:

> Hi,
> 
> we control some laboratory equipment with a LabJack U3-HV interface.
> The manufacturer of the interface provided a dll file and a Delphi
> wrapper for the dll file to read and set the ports of the interface.
> This works well with Delphi XE2.
> 
> But when I try to migrate to Lazarus 2.0, this wrapper is not
> accepted. It appears a error message 'Calling convention doesn't
> match forward'. Delphi XE2 doesn't complain about any convention
> difficulties in the wrapper file. I tried to harmonize the calling
> convention prescriptions in the interface and the implementation part
> of the wrapper- no success.

Have you tried compiling with {$mode delphi} instead of {$mode objfpc}?

 
> Is this a Lazarus or FPC bug, or a (perhaps undocumented) 
> incompatibility between Delphi XE2 and Lazarus 2.0? 

It is documented. For example:
https://www.freepascal.org/docs-html/prog/progse74.html

> Or do I oversee 
> something? We are using Win 10, Version 1809 (64). The wrapper
> itself can be downloaded from
> http://transfer.joepgen.com/wrapper.pas

Mattias


More information about the lazarus mailing list