[Lazarus] Keyboard mapping probelm

Brian b_lists at patandbrian.org
Tue Jun 2 12:13:12 CEST 2020

On 5/31/20 8:47 AM, Brian via lazarus wrote:
> On 5/30/20 6:56 PM, Graeme Geldenhuys via lazarus wrote:
>> On 30/05/2020 9:04 pm, Brian via lazarus wrote:
>>> Copyright (c) 1993-2017 by Florian Klaempfl and others
>>> (1002) Target OS: Linux for x86-64
>>> (3104) Compiling fcllaz.pas
>>> /home/brian/subversion/lazarus/packager/registration/fcllaz.pas(11,3) Fatal: (10022) Can't find unit db used by fcllaz
>>> Fatal: (1018) Compilation aborted
>>> Makefile:2929: recipe for target 'fcllaz.ppu' failed
>> From that errer, that tells me you have some problem with your FPC
>> setup, not Lazarus. FPC is trying to compile the Lazarus fcllaz
>> package that uses the FPC's db.pp unit, but can't find it.
>> The "db.pp" unit is part of FPC's fcl-db package. I would double
>> check your ~/.fpc.cfg file and make sure all the paths are correct.
> Well, I guess things are progressing, after a fashion!
> Thank you, Graeme, for sorting this one. I took the two fpc debs
> currently with the latest lazarus on sourceforge, installed them, and
> now lazarus (from subversion, and I updated this morning, before
> building) builds without error. So far, so good.
> So then I ran up the IDE, and changed to the QT5 widgets, per John's
> suggestion, and rebuilt the IDE. Nope! Back to this error which Don
> Alfredo says is due to an outdated libQT5pas.so when fpcupdeluxe is
> used, so I assume it's the same problem here.
> A quick search on the error finds details of building the Qt5 on a
> previous version of Mint
>> https://tondrej.blogspot.com/2018/04/first-steps-with-lazarus-qt5-interface.html
> which seems to be downloading an update of some of the QT5 stuff, so
> I'll try this lot when I get chance.
> In the meantime, my Gtk2 build running under the Debian-based version
> of Mint in a VirtualBox VM continues to work just fine - so whatever
> the cause of all this, it seems that EITHER it rests with the Ubuntu
> version of Mint OR it's a multi-way interaction with some of the
> software I have installed on the host but not on the VM.

I decided to try the multi-way interaction idea, and I reinstalled
Mint Ubuntu, reformatting the root partition. Lazarus now works
perfectly using gtk2, no 'i' and 'm' problems. :) I don't have
everything installed again, I cut thinks back to the minimum that I
must have, so I guess the thing now is to test Lazarus before and
after I install anything else, see whether I can find the installation
which breaks things, if in fact it still does.

If there was anybody else but me seeing this problem, then that's my
recommendation if you can do it, reinstall your OS and you may find it
all goes away. It certainly took less time than all the other things I
did trying to solve the problem.

Thanks again to everyone who tried to help.


More information about the lazarus mailing list