[Lazarus] Linux GNU Debugger Freezing App on Run

Anthony Walter sysrpl at gmail.com
Mon Mar 9 11:45:16 CET 2020

Has anyone else experienced the following problem?

I continually have a problem where running a program on Linux with the GNU
debugger through Lazarus results in either no control showing on my form or
controls show but everything is frozen.

This happens occasionally, probably on about 50% of the times I run and
program through Lazarus with debugging on. This happens with any program I
create with Lazarus on Linux when running an app through the IDE with
debugging on. If I turn off debugging or run my application through the
Linux desktop, it runs fine without any of the freezing.

So it would seem this problem is tied to Lazarus and how it interacts with
the GNU debugger. I have tried many version of Lazarus through SVN and I
get the same behavior. I am on Ubuntu 16.04 64-bit Linux.

My gdb debugger version is GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.5) 7.11.1
My Linux kernel version is Linux 4.15.0-88-generic
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20200309/0936ca0b/attachment.html>

More information about the lazarus mailing list