[Lazarus] Keyboard mapping probelm

Brian b_lists at patandbrian.org
Mon May 11 21:26:52 CEST 2020

On 5/7/20 8:08 AM, wkitty42--- via lazarus wrote:
> On 5/6/20 6:33 PM, Brian via lazarus wrote:
>> What I intend to do is to run some searches of my entire tree,
>> looking for
>> anything with lazar or fp in the name. Once I've got that
>> information, I'll
>> work through the lists and delete anything that looks fpc or lazarus
>> related.
>> Then I'll try fpcupdeluxe with another copy of trunk, and see
>> whether it fixes the problem. It will take some time.
> if you are on linux, something like this would be fairly quick and
> easy to use...
> sudo find / -type d \( -path .git -o -path .svn -o -path .cvs \)
> -prune -o -type f \( -iname "*.conf" -o -iname "*.cfg" -o -iname
> "*.cnf" \)
> it should find every *.conf, *.cfg, and *.cnf file on the system while
> skipping all .git, .svn, and .cvs directories... you really don't need
> to dig through all of those, in most cases, ya know? ;)
> once you have the list of matching files, then you can work through it
> looking for lazarus and fpc related configuration files... remember
> that not all of them will start with laz or fp...
> while testing the above on my system which i've recently removed
> lazaruz and fpc from for needed drive space, i found a leftover
> fppkg.cfg in my ~/.config directory... knowing that directory was used
> for some things then lead me to look at it closer... i found a lazarus
> directory in there with a reg.xml apparently from the jedi tool(s)
> along with a lhelp directory with a conf for the lazaruz lhelp tool...
> i also found a few left over fpc.cfg files in several project
> directories but those i kept because they contained only information
> on the project and nothing specific to lazarus or fpc...
> hopefully the above find command will be helpful to you... i keep a
> copy of it in one of my hint files so i don't lose it from my command
> history ;)

I tried both methods of generating a list of configuration files, and
I worked down both lists looking for anything which seemed fpc/lazarus
related, and deleted everything I could find. I then deleted back
fpcupdeluxe's target directory, and went through my home directory
looking for hidden directories. In short, I deleted every damned thing
I could find!

I then reinstalled, via fpcupdeluxe, copies of trunk for both fpc and
lazarus. According to fpcupdeluxe, everything compiled and built

I ran lazarus via the link provided by fpcupdeluxe, and tried typing
some text. NO change whatsoever. :( A lower case 'i' still produced
tab and 'i', and a lower case 'm' produced a line feed.

At this point, I think I give up. I don't want to switch my main
system to LMDE, so I will just run lazarus under LMDE in a virtual
machine, where the 'i' and 'm' keys work exactly as expected, and use
a shared folder, pointing a logical link to my source tree.

I reiterate that I have NEVER (knowingly, I suppose) remapped a
keyboard nor used a macro while using lazarus.


More information about the lazarus mailing list