[Lazarus] Keyboard mapping probelm

Brian b_lists at patandbrian.org
Sat May 16 13:49:00 CEST 2020

On 5/14/20 7:59 AM, Graeme Geldenhuys via lazarus wrote:
> On 06/05/2020 1:19 am, Brian via lazarus wrote:
>> I forgot to add - I totally erased fpcup's entire tree and rebuilt
>> from scratch. No change.
> It's not about recompiling Lazarus. Probably more related to your
> customised settings in your $HOME/.lazarus/ directory.
> Start your lazarus from the command line with the paramater:
>   ./lazarus --pcp=/tmp/lazarus
> where "/tmp/lazarus" is a totally empty directory.  That should give you
> Lazarus with 100% default config values. If the problem goes way, then
> it's a key mapping issue in your ~/.lazarus/ directory.

I tried that. Now *every* keypress is duplicated. Thanks for the
attempt, though!

I now have a working setup by way of using lazarus in a Linux Mint
Debian virtual machine and using a shared folder with a link to my
source tree. Since I don't want to switch to LMDE totally, it's an
acceptable workround. I write the code via the VM and then compile and
debug under standard Linux Mint.

I had previously tried deleting both the ~/.lazarus and also a
~/.lazarus64 directory, with no effect on the problem.


More information about the lazarus mailing list