[Lazarus] Lazarus on Ubuntu 18.04.4 via VNC cannot find utilities

Bo Berglund bo.berglund at gmail.com
Sun May 24 22:21:31 CEST 2020

I have been using fpc/Lazarus on Windows and Raspbian Buster for years
and it has worked just fine.

Now I have installed fpc 3.0.4 / lazarus 2.0.8 in Ubuntu 18.04.4 LTS
on a repurposed HP notebook (8440w).
It seemed to work OK until I retrieved code via SVN that has worked on
Windows and Raspbian in order to build for Linux on Intel hardware.

When I load the project all is OK, but when I try to compile I get to
an error:

Error: resource compiler "fpcres" not found, switching to external

But fpres is built during installation of fpc/lazarus and the binary
is placed in ~/bin, which usually is available on path.

So it seems like on this Ubuntu machine the existing ~/bin dir does
not result in it being placed on PATH and therefore Lazarus is unable
to use it.

What can be done to fix this?

I access the Ubuntu Mate desktop via VNC from my Windows 10 main
computer because the notebook is not used actively (it sits in a
THis way of operation has worked just fine with Lazarus on Raspbian
(Raspberry Pi) for years, why not on Ubuntu 18?

And the /home/bosse/.profile file contains this:

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/.local/bin" ] ; then

So it should automatically add ~/bin to PATH, right?
But it is not happening, PATH does not have /home/bosse/bin at the

Any help appreciated!

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list