[Lazarus] Lazarus on Ubuntu 18.04.4 via VNC cannot find utilities

Bo Berglund bo.berglund at gmail.com
Mon May 25 08:28:26 CEST 2020

On Mon, 25 May 2020 07:36:55 +0200 (CEST), Michael Van Canneyt via
lazarus <lazarus at lists.lazarus-ide.org> wrote:

>On Sun, 24 May 2020, Bo Berglund via lazarus wrote:
>> Comment=Lazarus IDE 2.0.8
>> Terminal=false
>> Name=Lazarus 2.0.8
>> Exec=/home/bosse/dev/lazarus/2.0.8/startlazarus
>Set this to
>/bin/bash -l home/bosse/dev/lazarus/2.0.8/startlazarus --pcp=/home/bosse/.lazarus_2.0.8 %f
>and .profile will be read.
>I have a similar issue, and that is how I solved it.
>> So I wonder if maybe Lazarus has a similar setting?
>No, you must set the options on the desktop/menu entry that starts lazarus.
>> Or maybe VNC server does?
>You must run lazarus not by directly running the startlazarus, but by
>invoking the shell with -l option. You can create a script for it.

Something must have gone wrong here...
I changed the desktop file but no Lazarus showed up so I tried to run
the Exec command from a terminal instead:

bosse at polaris-ubuntu:~$ /bin/bash -l
--pcp=/home/bosse/.lazarus_2.0.8 %f

/home/bosse/dev/lazarus/2.0.8/startlazarus: cannot execute binary file

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list