[Lazarus] Lazarus on Ubuntu 18.04.4 via VNC cannot find utilities

Michael Van Canneyt michael at freepascal.org
Mon May 25 12:32:59 CEST 2020

On Mon, 25 May 2020, Bo Berglund via lazarus wrote:

>>> /home/bosse/dev/lazarus/2.0.8/startlazarus
>>> --pcp=/home/bosse/.lazarus_2.0.8 %f
>> You must omit the %f on the command line.
>> What happens if you do
>> /bin/bash -l -c '/home/bosse/dev/lazarus/2.0.8/startlazarus --pcp=/home/bosse/.lazarus_2.0.8'
> Now Lazarus starts up with the project loaded and the compile and
> build operations work OK! :)
> How can I change the desktop files so they also work?
> I tried to set the Exec like this (single line of course, newsreader
> wraps..):
> Exec=/bin/bash -l -c '/home/bosse/dev/lazarus/2.0.8/startlazarus
> --pcp=/home/bosse/.lazarus_2.0.8'
> Then Lazarus starts OK but again throws the error due to
> /home/bosse/bin missing from PATH.

Where is it added to the PATH ? Normally, if you do this in .bashrc or
.profile, the -l option forces bash to pick it up.

> It seems like if one could set PATH correctly to include ~/bin for the
> VNC environment all would be solved...

No, that won't help.

Because you don't know with what environment the desktop items are started.
My guess is these are started with a minimal environment.

That is what I experienced, and the above is how I solved it.
(Instead of bash I am using tcsh though...)


More information about the lazarus mailing list