[Lazarus] Possible bug in TFrame

Marcos Douglas B. Santos md at delfire.net
Mon Aug 16 14:06:06 CEST 2021

On Sun, Aug 15, 2021 at 9:03 AM Marcos Douglas B. Santos <md at delfire.net> wrote:
> On Tue, Jul 15, 2014 at 11:55 AM Darío J. Vázquez Arguija
> <dvazquez at cmw.insmet.cu> wrote:
> >
> > To Whom It May Concern:
> >
> > I have detected a possible bug in the frames of Lazarus (1.0, 1.2.2, 1.3trunk) the problem manifests itself when the implemented component is embedded in frame and then try to run the program, which throws an error (The Control'' has no parent window), fortunately I don't have to send my code for some of their own components manifests.
> >
> > Please install the customdrawn package that comes with lazarus, create a frame insert one CDPageControl create CDTabSheet a page or two and then try to insert the frame within a form. It goes without saying that out of the frames components work perfectly .....
> >
> > This is a bug already known??
> I'm using the original mail above (2014!) because the same problem
> still exists in the current version.
> This won't happen with all frames, but just ones that have components
> with published properties as TCollection type, for example.
> Using fpcupdeluxe on Windows:
> - first, I have installed the version that still uses SVN (FPC 3.2.0
> rev 45643, Laz rev 64642), and the problem still there;
> - then, I have used the new fpcupdeluxe version that uses Git instead
> SVN, selecting the branches fpc-3.2.0 + laz-stable, and the problem
> still there;
> - then, keeping FPC as 3.2.0 (from now on), I selected the branches
> fpc-3.2.0 + laz-2.0.12, and the problem still there;
> - then, I have tried using branch fixes-2.2—which we couldn't use it
> in production yet, as I realized this branch has renamed some
> packages/components, adding "Laz" as prefix, which will broke the
> projects for the team which I'm work with—and the problem still there;
> - almost giving up, I have tried a downgrade for 2.0.10 (which uses
> rev 63526)—only testing—and the problem still there;
> - finally, I have tried using the trunk (Lazarus 2.3.0 rev
> main-0-gfb27fcd12a).... and the problem is still there!!!  :\
> I believe anyone can reproduce the same explained above using any
> component that has at least one published property as TCollection.
> Can someone propose a solution and merge it on, at least, fixes-2.0 please?

This didn't work either:

Problems with Frames are very old...

Marcos Douglas

More information about the lazarus mailing list