[Lazarus] Masks: the naming of ...

Bart bartjunk64 at gmail.com
Wed Oct 27 17:50:47 CEST 2021


I thought I better start a new therad for this one, otherwise I get
lost in the previous "TMask revisited" thread.

I would like to rename some stuff, now we still can.

Easier to remeber IMO:
WindowsQuirksAllAllowed -> AllWindowsQuirks
WindowsQuirksDefaultAllowed -> DefaultWindowsQuirks

MaskOpCodesAllAllowed -> AllMaskOpcodes
MaskOpCodesDefaultAllowed -> DefaultMaskOpcodes

property RangeAutoReverse -> AutoReverseRange

Internal consistency:

TMaskWindows -> TWindowsMask
TMaskListWindows -> TWindowsMaskList
(Because of the Matches* functions we already have)

Consitent coding style:
TMaskParsedCode enums: mpcXXX
TMaskFailCause enums: mfcXXX

Opinions please.


More information about the lazarus mailing list