[Lazarus] Strange linker messages "undefined reference" when building on RPi4 - CompileLog_2022-04-15.log (0/1)

Bo Berglund bo.berglund at gmail.com
Sun Apr 16 14:00:24 CEST 2023

On Sun, 16 Apr 2023 10:58:18 +0200, Bo Berglund via lazarus
<lazarus at lists.lazarus-ide.org> wrote:

>And now the project as checked out via subversion builds fine and works as it
>should. It builds both on Windows10 and on RaspberryPi4.
>So the errors I had before must be related to the older operating system
>(buster) and some missing dependencies maybe.

Well, this was *not* the main reason it turns out...

What I had done was to install the newest Lazarus/Fpc and opening the existing
project in lazarus.
When I use the Quick Compile it does apparently only compile the source files
and finishes OK.
But with Build/Compile it does the same but then it jumps into the linker
without also compiling the dependencies, which are present in the lib directory
but from the *earlier* versions...

I ran into this also on the newly installed RPi4 with bullseye Linux and then
realized what was going on because here I had two projects, one that had been
built previously and one that hadn't and the latter worked just fine as reported
above. Both were copied over from the old system SD-card...

So what I did now was to delete the lib dir below the project dir and now the
Build/Compile works just fine! It is recreated with fresh files.

So to keep in mind:
Make sure to remove any project subdirs autocreated by Lazarus/Fpc when
migrating a project folder.

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list