[Lazarus] Screwed up Lazarus installation - how to make clean and start over?

Bo Berglund bo.berglund at gmail.com
Tue Feb 21 19:18:28 CET 2023

I was trying to nail down the reason for the fppkg errors on start of Lazarus
I had the install running fine except for the Config screen showing up on every
start of Lazarus with an error message about fppkg...

So I proceeded to install my usual set of packages from OLPM, but when I had
selected the set I usually install and it was done and asked about rebuilding
Lazarus it did so and at the end closed itself and did not re-appear!
Now I cannot start Lazarus at all....

I tried to move the pcp dir away but it did not work either and starting with an
empty pcp dir does also not work.

So I tried to start over by going to the Lazarus dir and issue make clean, but
that did also not work:

~/dev/lazarus/2.2.4 $ make clean
Makefile:234: *** The Makefile doesn't support target can't-executed,, please
run fpcmake first.  Stop.

What would be the correct procedure now to start over?

Bo Berglund
Developer in Sweden

More information about the lazarus mailing list