[lazarus] LM_CLICK idea

Shane Miller smiller at lakefield.net
Wed Jul 7 22:40:17 EDT 1999


I was actually planning on setting LM_CLICK to an integer value and then in
gtkint.pp it woulds say:


case MESSAGE of
    LM_CLICK : Begin
    ...
                        end;
etc.

I didn't come up with generic names for LM_CLICK or anything.   I used
LM_CHECKRESIZE etc.  even though it's a bit GTK specific.  We can change
them later if we wish.
By assigning them a nuber, we are forced in GTKINT.PP to assign signal a
string value based on that number, BUT this allows us to do this

Procedure DoClick(var msg); message LM_CLICK;

and because that's an INTEGER value we can call Dispatch instead of
DISPATCHSTR .  At least I think we can.  That will help us remain more
multiplatform because dispatchstr is what SHOULD be called......


Shane

-----Original Message-----
From: Michael A. Hess <mhess at miraclec.com>
To: Lazarus-List <lazarus at miraclec.com>
Date: Wednesday, July 07, 1999 2:35 PM
Subject: [lazarus] LM_CLICK idea


>That is another good idea for the multi-API thing. This way a different
>file with the correct string for the API be it gtk or qt can be set for
>LM_CLICK and then we don't need to do the switching thing you indicated
>before.
>
>Where are you at with the code. I'd like to look at it and help some
>more tonight but I don't want to play with code that you have already
>done a alot of work on. Are you at a point where you can send me a cut
>of the code? If so just send it to the ftp site and others can get it as
>well.
>--
>==== Programming my first best destiny! ====
>
>Michael A. Hess      Miracle Concepts, Inc.
>mhess at miraclec.com   http://www.miraclec.com
>
>_________________________________________________________________
>     To unsubscribe: mail lazarus-request at miraclec.com with
>                "unsubscribe" as the Subject
>    archives at http://www.miraclec.com/list_archives/lazarus
>






More information about the Lazarus mailing list