[lazarus] Problem Compiling

Peter Vreman peter at freepascal.org
Mon Dec 18 02:43:54 EST 2000

> Hi all,
> I have been away for quite a while now. We bought a house and moved in and
> that has taken a lot of my time. Anyway, since I last did a CVS update,
> the FPC team has released V1 and it appears they are now working on 1.1.
> Now that I have done a CVS update, I cannot get the RTL to compile any
> more. I get the following error:
> system.pp(22,36) Error: Illegal unit name: SYSTEM
> system.pp(27,1) Fatal: There were 1 errors compiling module, stopping
> make[1]: *** [system.ppu] Error 1
> make[1]: Leaving directory `/opt/fpc/rtl/linux'
> make: *** [linux_all] Error 2
> I am just going into the rtl directory and doing a make. I also tried
> "make RELEASE=1" and still get the same error. I'm using the last version
> of the compiler that I compiled before V1 was released (from the August
> timeframe). Do I need to download a newer version of the compiler binary?
> Does anyone know why I am getting this error and what I need to do to
> correct it?

You need to start with the 1.0.2 release compiler.

But atm you can also better use the 1.0.x released compilers as the 1.1 is less stable

More information about the Lazarus mailing list