missing files (Solved ?)

Marc Weustink marc at lazarus.dommelstein.net
Tue Aug 21 19:40:53 EDT 2001

At 11:00 21-08-01 +0200, you wrote:
>+ Marc Weustink wrote:
>+ >
>+ > This morning I realized that you are probably using a fpc rpm of
>+ > 20010802 or 20010613. Maybe the Package.fpc support is
>+ > added later. So
>+ > can you try the 20010815 version. It contains the latest fpcmake.
>+ This still didn't work. I had to go through a few hoops to get the RPM
>+ to install (won't explain) but I have now installed the
>+ 20010815 version
>+ of the binary release of FPC. I confirmed that it did install a new
>+ version of fpcmake as well.
>+ When I do a build I still get exactly the same error with the fpcmake
>+ call ...
>+ An unhandled exception occurred at 0x0805ED78
>+ s_package_not_found rtl
>+    0x0805ED78
>+    0x00000000
>+ It is looking more and more like I MUST have the FPC source to make
>+ things work.    :-\
>Ok, I'll try this at home. (rename the fpc dir). I can't see how fpcmake
>knows my source fpcdir. (it is exported to /usr/lib/fpc = no sources)

Pfffff..... found it :-)

When fpcmake (version 20010815) tries to write a Package.fpc file it wants 
to check all platforms (it hasn't this behaviour when writing Makefiles, 
which I used to check).
When searching for Package.fpc it looks in the lib/fpc/1.0.5 dir and the 
lib/fpc/1.0.5/units/[platform] dir. The tar.gz with the missing Package.fpc 
files was extracted in the lib/fpc/1.0.5/units/linux dir, so when writing 
the package file it wants also to have a rtl/Package.fpc in the go32v2 dir 
(and all other platform dirs).
That was where your missing rtl error was from.

* Remove all Package.fpc files from the lib/fpc/1.0.5/units/linux/* dirs
   (in the dir: rm `find -name Package.fpc`)
* Extract the missing packages tag.gz in the lib/fpc/1.0.5 dir.

By trying to fix this problem I ran into a fpcmake bug (?)
When there is a Package.fpc in both lib/fpc/1.0.5/[package] and 
lib/fpc/1.0.5/units/[platform]/[package], fpcmake also reports an error of 
a missing [package]. Somehow internally it returns both dirs as one.


More information about the Lazarus mailing list