[lazarus] some IDE problems and more

Jesus Reyes jesusrmx at yahoo.com.mx
Sat Dec 14 15:33:22 EST 2002

Hi, I have some problems with current lazarus version
(13-dec-2002 cvs updated):

1) Some editor hotkeys doesn't work since i first
tried lazarus (ctrl+F9, markers ctrl+0..9, sctrl+0..9
for example) but others does ( ctrl+s, ctrl+o). I
tried to change key mappings in the past but IDE
crashed and was very difficult to recover so I'm
afraid to do it again ;). 

2) While double clicking components on form editor or
pressing "..." on events in object inspector does
locate/create corresponding event code, it doesn't
show the text cursor (maybe a setfocus is missing?)

3) If I insert one group of buttons, create its events
handlers and then wanted to change components name's
all seems to work but the corresponding events handler
names doesn't change (I can't express it correctly in
english, sorry) I mean:
a) before rename: button1CLICK(..) 
b) rename button1->btnChoose
c) after rename: button1CLICK(..)  But IMHO it should
be btnChooseCLICK().  This is a problem because if you
add another button the name assigned to it is:
button1!, and all kinds of funny things happen.

4) TScrollingwincontrol doesn't support child
controls, i mean, while you can set for ex
Edit1.parent:=Grid1.Parent, edit1.setfocus fails!
(sorry I don't remember error message but it was
somthing related to fixed widget)

5) I tried to install grids components in the IDE so I
followed instructions on customidecomps.pas and build
lazarus but doesn't work!, trying to find why i
noticed that no single file on lazarus tree references
customidecomps except by the file it self. I'm missing

6) For the next it would be easier to download
mysql_querier form http://mx.geocities.com/jesusrmx/
to see what I mean [the english problem again :(].
I was trying to find out why grid.anchors does reduce
its bounds to the original created ones (look at
Form1CREATE in main form) so I started to find anchors
property (ctrl+click: what i nice feature!) that took
me to published anchors property in grids.pas,
ctrl+click again on anchors  property should take me
to ancestor anchors declaration but it won't. A error
about it can't find stdctrls on the console appears 
TCodeToolManager.HandleException: "unit not found
StdCtrls" at line ...., Ctrl+clicking or Ctrl+Enter on
grids.pas stdctrls uses declaration wont work, Now the
funny thing, if I go to the mainunit.pas editor window
and tried ctrl+clicking or ctrl+enter on its stdctrls
uses declaration it works!.
I've added the path to grids.pas on run->compiler
options->Other unit files and other sources.
Compiling it's fine but browsing files "external to
proyect directory" doesn't work or again is something
bad in my setup?.

7) Menu items (appart from mainmenu) don't show
undelined character, "&Edit"

8) You can show Scrollbars in TScrollinwincontrol with
visible:=true but visible:=false dont hide them.

is someone working on TAction & TAction list

More later.

Jesus Reyes A.

Do You Yahoo!?
La mejor conexión a internet y 25MB extra a tu correo por $100 al mes. http://net.yahoo.com.mx

More information about the Lazarus mailing list