[lazarus] I can't compile Lazarus in Mandrake 9 (stupid question I'm sure)

Mattias Gaertner nc-gaertnma at netcologne.de
Tue Oct 29 18:05:15 EST 2002

On Tue, 29 Oct 2002 16:33:11 -0600 (CST)
"Tony Maro" <tony at maro.net> wrote:

> Mattias Gaertner said:
> >
> > Also make sure that the unitpaths in /etc/fpc.cfg points to your fpc
> > lib directory.
> >
> Aha!  Thanks.  It seems the samplecfg script included with FPC has
> changed somewhat.  

Right. The samplecfg script is ok, but it is sometimes called with the
wrong parameters. For example 'make install' under debian installs under
/usr/local/lib and calls samplecfg with /usr/lib. Perhaps this is work
for the fpc-team.
OTOH you should have been able to fix this on your own with the lazarus
FAQ. We can add a further hint. What do you think, I should add?


> Where before you would give it /usr/local as the path to FPC, now
> you must give it /usr/local/lib/fpc/fpc-1.0.7 as the path.  Either it
> changed or I've had it wrong all this time which would make me wonder
> why my install ever worked to begin with...
> I've updated my Lazarus install HOWTO to reflect this.
> Anyway, it works now.
> Thanks,
> Tony
> _________________________________________________________________
>      To unsubscribe: mail lazarus-request at miraclec.com with
>                 "unsubscribe" as the Subject
>    archives at http://www.lazarus.freepascal.org/mailarchives

More information about the Lazarus mailing list