[lazarus] I can't compile Lazarus in Mandrake 9 (stupidquestion I'm sure)

Tony Maro tony at maro.net
Tue Oct 29 21:21:10 EST 2002

On Tue, 2002-10-29 at 17:12, Mattias Gaertner wrote:
> > 
> > Aha!  Thanks.  It seems the samplecfg script included with FPC has
> > changed somewhat.  
> Right. The samplecfg script is ok, but it is sometimes called with the
> wrong parameters. For example 'make install' under debian installs under
> /usr/local/lib and calls samplecfg with /usr/lib. Perhaps this is work
> for the fpc-team.
> OTOH you should have been able to fix this on your own with the lazarus
> FAQ. We can add a further hint. What do you think, I should add?

Probably should be in there.  I ran the samplecfg by hand last install
and this install and got different results.  On the older version it
added the /fpc/... path stuff to what I gave it (/usr/local), on the
recent version it doesn't.  

So, FAQ should go something like "I get "can't find unit GLIB" [or other
basic library] when compiling Lazarus for the first time"  A: "Your
fpc.conf file for FPC is either missing or has incorrect paths to the
unit files installed with FPC.  Check your FPC paths or regenerate it
with the samplecfg script included with FPC."

Can anyone cram a few more "FPC"'s in the above for me?  I ran out of
breath... :-}

To be honest, though, the above Q/A wouldn't have helped me much the
first time I tried to run FPC / Lazarus, but I'm not sure how you can be
more specific and still apply to all installs of FPC.  But for complete
newbie's, we do have the HOWTO, and I updated it to take into account
this change in samplecfg.


More information about the Lazarus mailing list