[lazarus] TImage not displaying image?

Tony Maro tonym at nlisc.com
Thu Sep 5 11:42:55 EDT 2002

On Thu, 2002-09-05 at 11:32, Michael A. Hess wrote:
> > I did one better.  It's posted at http://tony.maro.net/testcrash.tar.gz
> > for anyone who's interested in trying it.
> Tried it. Didn't work for me either.  :-)

Andrew found that my compiled app didn't work, but when he recompiled my
source with no changes, it did.  His compiled app worked on my PC so (as
per Andrew's suggestion) it's something in the compiler / linker on my
end?  Perhaps it only works on Andrew's computer and HE'S the problem! 
LOL (just kidding)

I've since removed my install of FPC from the ELF.tar and reinstalled
using the RPM's.  I still can't compile the app and make it work.  Same

Any other ideas out there?  My apps will be rather boring without
graphics in them...

On a side note, I found that I can create a TBitmap and use the
loadfromfile method for it without a crash, but when I try the
loadfromfile method of the TIMAGE it fails every time.  Perhaps
something in the interpretation of the file type is amiss with a unit on
my PC's?

I'm a little rusty... can someone give me an example of assigning a
TBitmap to a TIMAGE once I've loaded it into the TBitmap?  


mybitmap := TBitmap.Create;
image1.Picture.Bitmap := mybitmap;

Would something along these lines be valid, or do I use the ASSIGN


More information about the Lazarus mailing list