[Lazarus] unknown property LCL-Version ...

Mattias Gaertner nc-gaertnma at netcologne.de
Sat Mar 8 20:11:19 CET 2008

On Sat, 08 Mar 2008 18:31:03 +0000
hy-soft <hy-soft at sha-mash.de> wrote:

> Mattias Gaertner wrote:
> > Normally you just need to recompile the application with the same
> > LCL as the IDE was built with.
> Yeah, that was true until beginning of this week.

It's still true.
Properties are added all the time. This is just a further string

> >> I tried to remove it by editing the *.lrs manually but keeps beeing
> >> reinserted which is a drag
> > 
> > Is this a normal LCL application or a special thing like KOL?
> I do not know what KOL is.
> It is just a regular application. I ported it from Delphi and it
> worked already with win and Linux.
> The only thing that seems to be important is that the forms in
> question are inherited from basic forms.
> Yes, i have altered the *.lfm files and inserted *inherited* insted of
> object.
> any help apperciated.

The error message means: The property was not found in the RTTI - run
time type information.
The RTTI is created by the compiler from the published properties.
That's why you must compile your project with the same LCL version as
the IDE.
If you compile your project with old LCL ppu files you will see the
Please make sure, that you compile with the same LCL as the IDE. Take a
look in the compiler options / show options.

Can you send an example?

> And sorry for the multiple posts - i had trouble with one of my
> mailservers recently so I reposted the matter after it didn't appear
> on the list.


More information about the Lazarus mailing list