[Lazarus] A new competitor to Lazarus and Free Pascal

Graeme Geldenhuys graemeg.lists at gmail.com
Tue Nov 25 15:39:21 CET 2008


I've set two bookmarks using Ctrl+1 and Ctrl+2 (luckily only two). :-)
 But now for the life of me I can't unset them!  In Delphi I can
simply press Ctrl+1 again while I'm on the (1) bookmark and it will
toggle (set/unset) the bookmark.  But Lazarus clearly doesn't do that
- toggle bookmarks.

I even tried to restart the Lazarus IDE, but those bookmarks are very
persistent buggers!! They are still there.  :-(

I also tried the "Search | Set a free bookmark" though to be honest I
have no idea what that menu item is supposed to do - but from the
description, I thought it might work but it didn't.  If it was
supposed to work, it's a very weird method of doing so, I much prefer
the Delphi way.

I take it bookmarks are not used by anybody, otherwise somebody would
have detected the same issues as I now have. Is the Ctrl+<number> a
toggle feature like Delphi and it's just broken in Lazarus, or does
Lazarus IDE work fundamentally different?

  - Graeme -

fpGUI - a cross-platform Free Pascal GUI toolkit

More information about the Lazarus mailing list