[Lazarus] Lazarus and SPARC Solaris

Mark Morgan Lloyd markMLl.lazarus at telemetry.co.uk
Tue Dec 21 19:27:29 CET 2010

Mark Morgan Lloyd wrote:
> Marco van de Voort wrote:
>> On Mon, Dec 20, 2010 at 01:22:19PM +0000, Mark Morgan Lloyd wrote:
>>>> If you can confirm that it works, I'll enable it.
>>> OK, I'll get onto it later. In this context what constitutes working- 
>>> that it compiles without error or is there a functional test?
>> Compile and link (the iconv lib is "special" on some *nixes), and 
>> there is a
>> test from Ido in examples, testing with some Hebrew iirc.
>>>> Probably you want to make a difference between the solaris line and the
>>>> FreeBSD (this avoids some inheritly Linux specific packages) line 
>>>> there, and
>>>> test which packages work with solaris.
> The packages in Solaris appear to be a strict subset of those in 
> FreeBSD, missing aspell gdbint gmp graph gtk2 iconvenc librsvg libxml 
> pxlib sdl users.

iconvenc compiles and the test runs although the output is Greek to me. 
This is the only one I've tried so far.

Building Lazarus with  gmake LCL_PLATFORM=gtk all  (i.e. not yet trying 
bigide) runs most of the way through, until it gets to

gmake -C ide ide
gmake[1]: Entering directory `/export/home/share/lazarus-trunk/ide'
/usr/bin/mkdir -p ../units/sparc-solaris
./tools/svn2revisioninc .. revision.inc
gmake[1]: execvp: ../tools/svn2revisioninc: Invalid argument
gmake[1]: *** [revisioninc] Error 127
gmake[1]: Leaving directory `/export/home/share/lazarus-trunk/ide'
gmake: *** [ide] Error 2

The "Invalid argument" message appears to be coming from svn2revisioninc 
itself, running it with -v gives me the same message with no additional 
information and I haven't yet started trying to work through what's 

The directory tree I'm compiling contains .svn directories etc. but I've 
not yet tried to install svn on Solaris 10, the available binary appears 
to want library patches which I'm not very enthusiastic about at this 
stage- I'd much rather be testing on a virgin system. However I think 
this is a red herring since if I rename ./.svn I still get the same error.

Anybody got any suggestions?

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

More information about the Lazarus mailing list