[Lazarus] Lazarus and SPARC Solaris

Mark Morgan Lloyd markMLl.lazarus at telemetry.co.uk
Tue Dec 21 20:23:58 CET 2010

Mark Morgan Lloyd wrote:

> iconvenc compiles and the test runs although the output is Greek to me. 
> This is the only one I've tried so far.
> Building Lazarus with  gmake LCL_PLATFORM=gtk all  (i.e. not yet trying 
> bigide) runs most of the way through, until it gets to
> gmake -C ide ide
> gmake[1]: Entering directory `/export/home/share/lazarus-trunk/ide'
> /usr/bin/mkdir -p ../units/sparc-solaris
> ./tools/svn2revisioninc .. revision.inc
> gmake[1]: execvp: ../tools/svn2revisioninc: Invalid argument
> gmake[1]: *** [revisioninc] Error 127
> gmake[1]: Leaving directory `/export/home/share/lazarus-trunk/ide'
> gmake: *** [ide] Error 2
> The "Invalid argument" message appears to be coming from svn2revisioninc 
> itself, running it with -v gives me the same message with no additional 
> information and I haven't yet started trying to work through what's 
> happening.
> The directory tree I'm compiling contains .svn directories etc. but I've 
> not yet tried to install svn on Solaris 10, the available binary appears 
> to want library patches which I'm not very enthusiastic about at this 
> stage- I'd much rather be testing on a virgin system. However I think 
> this is a red herring since if I rename ./.svn I still get the same error.
> Anybody got any suggestions?

Skip that one for the moment- I can get past using  gmake 

Now I'm stuck at this point which looks a bit more tricky:

Compiling lazarus.pp
Fatal: Can't find unit clocale used by Lazarus
Fatal: Compilation aborted
gmake[2]: *** [lazarus] Error 1
gmake[2]: Leaving directory `/export/home/share/lazarus-trunk/ide'
gmake[1]: *** [ide] Error 2
gmake[1]: Leaving directory `/export/home/share/lazarus-trunk/ide'
gmake: *** [ide] Error 2

I can see this in lazarus.pp:

   {$IF defined(Unix) and not defined(VER2_2_0) and not defined(VER2_2_2)}

I can see clocale RTL files:


I presume that I need to do something like finding why clocale.pp isn't 
being compiled for Solaris (i.e. Makefile.fpc somewhere), copy 
bsd/clocale.inc to solaris/clocale.inc, and modify clocale.pp to include 
it if being compiled for Solaris- at present the options appear to be 
BSD or Linux.

Could somebody please confirm or tell me that I'm heading in the wrong 

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

More information about the Lazarus mailing list