[Lazarus] Fatal: Can't open include file "fileutil.inc"

Vincent Snijders vincent.snijders at gmail.com
Sat Nov 13 21:52:53 CET 2010

2010/11/13 Christof Kluß <ckluss at email.uni-kiel.de>:
> Hi,
> I installed the recent Lazarus snapshot, but when I try to compile my
> project I get the error message
> C:\lazarus\lcl\fileutil.pas(237,2) Fatal: Can't open include file
> "fileutil.inc"
> I tried
> Lazarus-
> Lazarus-0.9.29-28197-fpc-2.4.3-20101113-win32.exe
> then I installed again the recent beta version
> lazarus-
> but now with every version I get the same error at {$I fileutil.inc} in
> the FileUtil.pas. I recompiled Lazarus, but there is still the same
> error...
> Did you have an idea what I did wrong?

Hard to tell. Maybe you added LCL *source* paths to your compiler
options, instead of adding the LCL as a requirement in the project

Compile the project with the options -vu -vt and inspect all
(including hidden) messages to see if some unit is out of place.


More information about the Lazarus mailing list