[Lazarus] Multiple FPC versions for Lazarus

Bo Berglund bo.berglund at gmail.com
Sun Nov 14 08:30:25 CET 2010

I have downloaded and installed FPC 2.4.2 into my Lazarus install tree
under fpc where I already had subdir 2.2.4. So I installed FPC into
subdir 2.4.2.
Lazarus itself was installed from the official SourceForge Windows
distribution lazarus-

But when I tried to compile Lazarus for the new FPC version it failed,
probably because of lack of understanding of the process...

I did this immediately after installing FPC (with Lazarus completely
shut down):

CD C:\Programs\lazarus
C:\Programs\lazarus\fpc\2.4.2\bin\i386-win32\make.exe clean all

There was a lot of activity on screen and then at the end there was an
error (now gone so I can't say which error it was).

To restore Lazarus I changed the command above by replacing the 2.4.2
folder with 2.2.4 and this time the process succeeded, but of course
it uses the old version of fpc.

What is the proper procedure to switch lazarus from using fpc
2.2.4 to fpc 2.4.2??
Is there some config file that needs editing too? If so, where is it
Or is there a command line switch to make that tells it which fpc to

I suspect that what I did was just to use the make utility from 2.4.2
but still the compiler from 2.2.4. I have tried to find out via Google
but failed.

Bo Berglund

More information about the Lazarus mailing list