[Lazarus] Problems with the v0.9.30 AMD 64 DEBs on Sourceforge

Mattias Gaertner nc-gaertnma at netcologne.de
Tue Apr 5 12:48:48 CEST 2011


brian <brian at meadows.pair.com> hat am 5. April 2011 um 11:11 geschrieben:

> Hi all,
> I downloaded and installed the AMD 64 DEBs from Sourceforge, cleaned
> off my 0.9.28 setup onto DVD and then installed v0.9.30 from scratch.
> The process has been a bit fraught. :( This is all using Linux Mint 9,
> which is a fork from Ubuntu.
> The first problem was that installing the DEBs gives a couple of
> unresolved dependencies, basically the QT4 stuff. Don't use QT4, so I
> can ignore that, Lazarus still started up OK after a apt-get -f, so no
> worries there. 
Perhaps you tried to install the

> Next thing missing was one package, pack_powerpdf or something like
> that, but I knew I'd seen that in the CCR, so no problems, download
> and install that. Then there were a few file and directory permissions
> to be changed. 
Can you give some more details?
Maybe this can be added to the installation hints.

> Now the problem which has got me stuck - trying to rebuild Lazarus
> from within the IDE, I get an error
> /usr/lib/lazarus/0.9.30/ide/idecmdline.pas(1,1) Fatal: Can't find unit
> exploreidemenu used by Lazarus 
The unit Exploreidemenu is an example package (examples/exploremenu). It is not
installed by default. Problably you had it installed in a former version and the
IDE tried to restore your old set of packages.
The debian package maintainer has set all packages (lpk files) to compile
"manually", even those that the debian packages not provided in compiled form
(ppu files).
Either uninstall the package exploreidemenu or open the package and compile it

> This is NOT some kind of mangled path problem - I used Dolphin to do a
> *case-insensitive* search of my *entire* file system for exploreidemenu.*
> No files were found.
> So, my question - I did, yes **I DID**, install all the .DEBs within
> those two files on Sourceforge, including both the FPC and the Lazarus
> sources. I don't want to end up with an incompatible set of sources,
> and I've not enough experience with Lazarus to want to work through
> building everything from an SVN download. Does anyone know if/where I
> can get a set of the sources used to build the release of Lazarus
> that's available on Sourceforge, so that I can try to fix the problem
> myself?
On Sourceforge are debs, rpms and zip. The zip contains only the sources.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20110405/e005aabb/attachment-0003.html>

More information about the Lazarus mailing list