[Lazarus] Problems with the v0.9.30 AMD 64 DEBs on Sourceforge

brian brian at meadows.pair.com
Tue Apr 5 14:54:10 CEST 2011

Hi Mattias,

On 04/05/2011 06:48 AM, Mattias Gaertner wrote:
> brian <brian at meadows.pair.com> hat am 5. April 2011 um 11:11 geschrieben:
>  > Hi all,
>  >
>  > I downloaded and installed the AMD 64 DEBs from Sourceforge, cleaned
>  > off my 0.9.28 setup onto DVD and then installed v0.9.30 from scratch.
>  > The process has been a bit fraught. :( This is all using Linux Mint 9,
>  > which is a fork from Ubuntu.
>  >
>  > The first problem was that installing the DEBs gives a couple of
>  > unresolved dependencies, basically the QT4 stuff. Don't use QT4, so I
>  > can ignore that, Lazarus still started up OK after a apt-get -f, so no
>  > worries there.
> Perhaps you tried to install the
> lcl-qt4-0.9.30_0.9.30-0_i386.deb
> ?

Unquestionably. As you know, the files on SourceForge unpack to 19 
.debs (FreePascal) and 13 .debs (Lazarus) with no indication as to 
whether there's any particular order in which to install them. I just 
took the unsubtle approach, unpacked each into their own subdirectory 
and then ran a couple of "sudo dpkg -i *.deb", first on the FreePascal 
directory and then on the Lazarus directory, figuring that if there 
was any sensitivity as to the installation order, the second pass 
would probably fix it.

>  > Next thing missing was one package, pack_powerpdf or something like
>  > that, but I knew I'd seen that in the CCR, so no problems, download
>  > and install that. Then there were a few file and directory permissions
>  > to be changed.
> Can you give some more details?
> Maybe this can be added to the installation hints.

I'm afraid I didn't keep a note of them. I do remember that there was 
an x86_64-linux somewhere in the path, but that won't come as too much 
of a surprise to you. :) Since I'm the only user of this PC, I just 
said the hell with it, did a recursive chown on
/usr/lib/lazarus  and had no further problems.

> The unit Exploreidemenu is an example package (examples/exploremenu).
> It is not installed by default. Problably you had it installed in a
> former version and the IDE tried to restore your old set of packages.

It's hard for me to prove a negative, but I really did take pains to 
remove the old version - I did an "apt-get purge" on both fpc and 
lazarus, and then did a search on both and removed anything else I 
could find.

> The debian package maintainer has set all packages (lpk files) to
> compile "manually", even those that the debian packages not provided
> in compiled form (ppu files).
> Either uninstall the package exploreidemenu or open the package and
> compile it manually.

I will give that a try, thanks.

> On Sourceforge are debs, rpms and zip. The zip contains only the sources.

Ah. I'd missed the zip file. Thanks for the pointer.


More information about the Lazarus mailing list