[Lazarus] Build Lazarus + MINGW32

Juha Manninen juha.manninen62 at gmail.com
Fri Jun 1 16:50:49 CEST 2012


I tried to "make all" for at my work Windows machine. I have git and
MINGW32 unix shell environment installed.
The build fails as shown below. The problematic line is clearly this:
  sh: C:\Program: No such file or directory
For some reason "sh" is started and it does not understand spaces in paths.
The interesting thing is that I use normal Windows cmd, not the MINGW32
If I test in MINGW32 shell, it gives the same error.

"$ which make" in MINGW32 shell says (correctly) :

I remember seeing questions of this problem also before. How to solve it?


Compiling noguiint.pp
Compiling noguiwsfactory.pas
735 lines compiled, 0.6 sec
C:/FPC/2.6.0/bin/i386-Win32/cp.exe -f Makefile.compiled
make[3]: Leaving directory `C:/SW/lazarus/lcl/interfaces/nogui'
make[2]: Leaving directory `C:/SW/lazarus/lcl/interfaces'
make[1]: Leaving directory `C:/SW/lazarus/lcl'
make -C tools
makefile:2332: warning: overriding commands for target `.'
makefile:2330: warning: ignoring old commands for target `.'
make[1]: Entering directory `C:/SW/lazarus/tools'
sh: C:\Program: No such file or directory
make[1]: *** [all] Error 127
make[1]: Leaving directory `C:/SW/lazarus/tools'
make: *** [lazbuild] Error 2
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20120601/0c28d104/attachment-0002.html>

More information about the Lazarus mailing list