[Lazarus] Build Lazarus + MINGW32

Henry Vermaak henry.vermaak at gmail.com
Fri Jun 1 17:17:30 CEST 2012

On 01/06/12 15:50, Juha Manninen wrote:
> Hi
> I tried to "make all" for at my work Windows machine. I have git and
> MINGW32 unix shell environment installed.

MinGW doesn't have a shell.  Do you mean MSYS?

> The build fails as shown below. The problematic line is clearly this:
>   sh: C:\Program: No such file or directory
> For some reason "sh" is started and it does not understand spaces in paths.

I had to patch the Makefiles to get my fpc and lazarus to build inside
msys.  Is this what you are trying to do?

> The interesting thing is that I use normal Windows cmd, not the MINGW32
> shell.
> If I test in MINGW32 shell, it gives the same error.
> "$ which make" in MINGW32 shell says (correctly) :
>   /c/FPC/2.6.0/bin/i386-Win32/make

You are using "make" supplied by fpc, so why mingw/msys?  I'm a bit
confused about what you are doing, but it looks like you can't build
lazarus even with the fpc supplied tools, so perhaps you have PATH issues.


More information about the Lazarus mailing list