[Lazarus] RE : Lazarus crashing reproducibly on startup (64-bitLinux)

Mark Morgan Lloyd markMLl.lazarus at telemetry.co.uk
Sat Mar 24 10:13:10 CET 2012

brian wrote:
> On 03/20/2012 04:59 AM, Mark Morgan Lloyd wrote:
>> brian wrote:
>>>> I fairly regularly build both FPC trunk and the current release on
>>>> multiple platforms (but markedly /not/ on x86-64) and in many cases
>>>> drop libgdb from FPC since it's only required for the fp IDE. Looking
>>>> at your list of undefineds, I think the right question would have been
>>>> "how can I build a vanilla libgdb that doesn't require a whole lot of
>>>> Python libraries etc."- and I'm afraid that's one for the gdb
>>>> developers rather than us.
>>> So you're telling me that *any* program which I need to build myself
>>> and which pulls in libgdb is going to have all those undefineds?
>>> That does sound to be a bit of a shortcoming if so! I did try
>>> installing a bunch of Python libraries as well, but didn't get
>>> anywhere.
>> I'm not going back to the October stuff right now, this could well be
>> a distro issue particularly if it's got a libgdb package but not the
>> underlying Python libraries. I'm afraid I've never been into Python:
>> my style's more Horne :-)
>>> Anyway, I shall keep bashing away at trying to get the svn versions
>>> to build and install, and see whether they cure the latest problem.
>>> It will take me a little while to get it done, but I'll report back
>>> if I manage to fix it - I'm not too keen on the alternative, which
>>> is trying to resurrect my Fortran from umpty-mumble years ago.
>> I'd suggest getting a working FPC 2.6.0, either as a binary (from the
>> FPC servers) or building it yourself although this might require that
>> you start with 2.4.4. In the latter case use something like
>> $ make NOGDB=1 OPT='-gl' all
>> followed by a make install , after which you'll probably want to make
>> sure that you've got /usr/local/bin/ppc386 ->
>> /usr/local/lib/fpc/2.6.0/ppc386 or similar (make install doesn't mess
>> with that symlink: I'm not sure that's a wise omission but it's the
>> way it is).
>> The NOGDB will make sure that there is no reference to libgdb, but as
>> I said earlier it is only required by the fp text-mode IDE.
>> Having to that point, get a recent Lazarus. Now I'm sure you've got
>> your own preferences, but the one that I've built most recently was
>> the fixes RC from SVN
>> svn co
>> http://svn.freepascal.org/svn/lazarus/branches/branches/release_0_9_30_4
>> ./lazarus-fixed
>> If you decide that you really do need libgdb, which you DO NOT if your
>> interest is Lazarus, then I suggest finding or building a copy around
>> v6.7.1 and then using make GDB_V607=1 OPT='... since this definitely
>> works on Debian (Etch/Lenny/Squeeze) x86 and others. HTH.
> Hi Mark,
> I tried rebuilding gdb and libgdb.a from source, making sure I had all 
> the Python libraries installed. That seemed to work OK, no errors. I 
> installed everything and tried rebuilding FPC with no switches. There 
> were less undefined globals, but still a lot of them.
> So then I followed your instructions.
> 1) Yes, FPC from svn will build correctly with the NOGDB switch you 
> provided. I did so, and installed it.
> 2) I downloaded the Lazarus that you indicate above. It built without 
> errors, but when I try to run it, it still comes up with the error 203. 
> Running under the debugger produces this output
> <paste>
> Runtime error 203 at $00000000006EFFDA
>   $00000000006EFFDA
>   $00000000006D90ED
> [Inferior 1 (process 4558) exited with code 0313]
> </paste>
> I've taken a look on the Linux Mint forums, and I certainly don't seem 
> to be the only one seeing this problem, as David's posting also suggested.
> I have two friends who are total non-programmers. Neither FPC nor 
> Lazarus will have been anywhere near their machines. One of them is 
> running Debian Testing, on which Linux Mint Debian (LMDE) is built, the 
> other is running LMDE as I am. Both are on 64-bit distros.
> I'm going to ask them both to try installing Lazarus and then try to run 
> it. If, as I suspect, the LMDE user sees the crash and the plain Debian 
> user doesn't, then I think that will be fairly conclusive.
> In the short term, I guess the best way out will be to set up a virtual 
> machine with a copy of some other distro and do any Lazarus work in that.
> I'm still a relative novice at Linux, though I've long experience with 
> Borland/CodeGear/Embarcadero Pascal/Delphi under Windows. If any of the 
> developers want me to try compilations etc. under LMDE, I'd be happy to 
> devote up to a couple of hours a day in doing so, but I'd need to be led 
> through most of it.
> Thanks for your help, and I'll report back when I hear from my friends, 
> although I will be very surprised if they do anything other than confirm 
> what I've found, i.e. Lazarus will run just fine on plain Debian but not 
> on LMDE.

Thanks Brian, I for one am watching with interest.

Mark Morgan Lloyd
markMLl .AT. telemetry.co .DOT. uk

[Opinions above are the author's, not those of his employers or colleagues]

More information about the Lazarus mailing list