[Lazarus] v1.0.8 - why would code navigation stop working?

Mattias Gaertner nc-gaertnma at netcologne.de
Wed Jul 3 16:24:16 CEST 2013

> Graeme Geldenhuys <graeme at geldenhuys.co.uk> hat am 3. Juli 2013 um 16:11
> geschrieben:
> Hi,
> What would cause code navigation (Ctrl+Click) to stop working in Lazarus
> IDE. I have the correct FPC source path, compiler path, packages etc.
> Compiling my projects work fine, but for the life of me I don't know why
> code navigation stopped working.
> I even tried switching between FPC 2.6.2 and 2.7.1 (compiler and source
> path), but that made no difference to Lazarus IDE.
> Lazarus in the same Windows 2000 VM works fine, but my
> installed Lazarus 1.0.8 doesn't.
> Maybe related to the above problem.... If I press Ctrl+Space to prompt
> code insight (list of available methods to an object) then Lazarus IDE
> *always* jumps to a code unit in fpGUI, and always to the 'contnrs' unit
> in the interface's uses clause. Yet, there is NO coding errors because
> the project compiles fine.

Is there an error message? Which one?

Have you tried Tools / Rescan FPC source directory?

Check if the FPC source directory points to the directory containing the 'rtl'
and 'packages' directory.


More information about the Lazarus mailing list