[Lazarus] Can not install a package

Haruyuki Fujimaki hryk_fujimaki at yahoo.com
Wed Jul 31 16:20:42 CEST 2013


According to your advice, I tried a clean build. Unfortunately, I got same error. So I created new package and added same components.
And I added "$(LazarusDir)/lcl/units/$(TargetCPU)-$(TargetOS)" and "$(LazarusDir)/components/lazutils/lib/i386-linux" to "Other unit files" in package options.
I also added lclbase to Required Package of the package.
Then, clean build was successful and the package has been installed.
Thank you for your advice.


>>  I am trying to install a package to 1.0.10 on Linux Mint 15, but have been 
> unable to install it receiving an error massage:
>>  "Fatal: Can not find unit <package_name> used by Lazarus. Check 
> if package <package_name> is in the dependencies."
>>  The package file is the same one successfully installed on 1.0.6 on Xubuntu 
> 13.04. So the problem seems strange for me.
>>  How can I inform Lazarus path of the package? 
> If you quoted correctly, then the IDE already knows the package,
> because it knows that an unit with the name <package_name> is in the
> package named <package_name>.
> Check if you can rebuild the IDE without this package.
> If that succeeds then either the package has a bug or you have some old
> files on your disk, which need to be deleted before building.
> Have you tried a clean build? Tools / Configure Build Lazarus / Clean
> All?
> Mattias
> --
> _______________________________________________
> Lazarus mailing list
> Lazarus at lists.lazarus.freepascal.org
> http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus

More information about the Lazarus mailing list