[Lazarus] Help: OS X Problems

Anthony Walter sysrpl at gmail.com
Sun Nov 3 03:54:08 CET 2013


Thanks. I've read those threads before. I actually have gdb installed
through macports and I signed it.


Good information. I ran lazarus with the command line options to log gdb
and this is the result:


Taking you suggestion to run ggdb from the command line, I followed your
instructions and notice something that might perhaps be the problem:


The effect is still the same, my window is disabled, but I noticed these

&"warning: stabs debugging not supported for controls.pp\n"
&"warning: stabs debugging not supported for
&"warning: stabs debugging not supported for comctrls.pp\n"

Could this be causing the problems? If stabs debugging is in my compiled
LCL units and exe, or perhaps in the FPC units, what would be the way to
remove them? I normally run "make all" in my lazarus directory. What would
be the way to "make all" for lazarus with the proper dwarf debugging
information for lazarus and the LCL units? Would I also need to rebuild my
FPC units as well?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20131102/35a5e53f/attachment-0003.html>

More information about the Lazarus mailing list