[Lazarus] Help: OS X Problems

Martin lazarus at mfriebe.de
Sun Nov 3 04:15:22 CET 2013

On 03/11/2013 02:54, Anthony Walter wrote:
> Dmitry,
> Thanks. I've read those threads before. I actually have gdb installed 
> through macports and I signed it.
> Martin,
> Good information. I ran lazarus with the command line options to log 
> gdb and this is the result:
> http://cache.codebot.org/stackoverflow/lazarus-worker-debug.txt

This is ok
   >> TCmdLineDebugger.SendCmdLn "-file-exec-and-symbols 

but a bit later
  << TCmdLineDebugger.ReadLn "~"Symbols from 
   << TCmdLineDebugger.ReadLn "~"Local exec file:\n""
   << TCmdLineDebugger.ReadLn 
"~"\t`/Users/macuser/Development/Projects/worker/worker', file type 

this is not ok.

IIRC, does the IDE create a sym link in the bundle? Maybe your gdb 
follows this.


- remove the symlink
- configure your project options, there is a field to specify where the 
final exe goes. Make sure it will be in the bundle

btw google:

> Taking you suggestion to run ggdb from the command line, I followed 
> your instructions and notice something that might perhaps be the problem:
> http://cache.codebot.org/stackoverflow/ggdb-worker-debug.txt
> The effect is still the same, my window is disabled, but I noticed 
> these warnings:
> &"warning: stabs debugging not supported for controls.pp\n"
> &"warning: stabs debugging not supported for 
> ./carbon/pascocoa/appkit/appkit.pas\n"
> &"warning: stabs debugging not supported for comctrls.pp\n"
no, that just means the debugger cant set breakpoints or read variable 
in those files.
recompile all packages with dwarf -gw

More information about the Lazarus mailing list