[Lazarus] IDE problems

brian brian at meadows.pair.com
Tue Nov 26 09:31:17 CET 2013

On 11/26/2013 03:21 AM, Mattias Gaertner wrote:
> On Mon, 25 Nov 2013 22:17:05 -0300
> Junior <lazarus.linux at gmail.com> wrote:
>> Fixing the link:
>> http://www.meadows.pair.com/Screenshot%20-%2011252013%20-%2006:57:09%20PM.png
>> Em 25-11-2013 21:49, brian escreveu:
>>> On 11/25/2013 06:45 PM, Mattias Gaertner wrote:
>>>> On Mon, 25 Nov 2013 18:26:48 -0500
>>>> brian <brian at meadows.pair.com> wrote:
>>>>> Hi folks,
>>>>> Something has spontaneously gone wrong with the IDE on my setup. I say
>>>>> spontaneously because I was in the middle of debugging a program when
>>>>> suddenly everything but the source window disappeared. I eventually
>>>>> had to abort Lazarus and re-start the program, but now I see some very
>>>>> strange behaviour :-
>>>>> 1) Pull-down menus stay pulled down, even when I've selected an entry.
>>>> What Lazarus version do you use?
>>>>> 2) Only the object inspector or the source editor can be visible at
>>>>> any one time - select one, and the other vanishes.
>>>>> There are probably a few other quirks too, but those are the most
>>>>> annoying two.
>>>>> In my Delphi days, there used to be a desktop configuration file which
>>>>> you deleted if the IDE got all screwed up, and then when you ran the
>>>>> program again you were back to all the defaults.
>>>>> Is there such a file for Lazarus? I assume this isn't a
>>>>> version-specific question, but anyway, I'm running Lazarus under
>>>>> 64-bit Debian multi-home, and the version is the latest as downloaded
>>>>> by fpcup_linux_x64 two days ago, SVN revision 43478.
>>>> The config files are under Linux in $HOME/.lazarus.
>>> Thanks, Mattias. I tried renaming .lazarus and then ran lazarus up
>>> again, but no change in the behaviour. Let me show you the sort of
>>> thing I see, screenshot attached. Any time I click a pulldown menu,
>>> the source window disappears, and as you will see, the pulldown menus
>>> stay there.
>>> P.S. Didn't know about the 100 KB size triggering a moderator review.
>>> OK, the .png is here.
>>>> http://www.meadows.pair.com/Screenshot - 11252013 - 06:57:09 PM.png
> I have never seen such a bug with the LCL.
> Does that happen only with Lazarus?

I tried OpenOffice, and its menus worked perfectly.

> What window manager do you use?


> Is that the LCL QT widgetset?

No, gtk2.

Anyway, as you will see from another posting, I ran out of patience 
with it and nuked the setup, then set it to rebuild overnight. The new 
setup works just fine, and the bit of reconfiguration needed is less 
frustrating than trying to use the corrupted(?) setup.

Thanks anyway,


More information about the Lazarus mailing list