[Lazarus] Help: OS X Problems

Anthony Walter sysrpl at gmail.com
Wed Oct 30 13:50:02 CET 2013

Earlier (after my initial post) I had found and read the same links you
posted. It feels god knowing I am on the right track, so thanks, thigh I am
still having problems.

Where I'm At

The lazarus revision 43255 you posted locks up at start due to the focus I
mentioned previously.

I deleted my lazarus folder, checked out revision 42619 again, built and
run and the IDE opens correctly again. I am using ggdb from macports as
mentioned earlier.

In a new project called 'hello' I set the run host application to

When I run I get a window titled 'Debugger Error' with the text 'Debugger
error. Ooops, the debuggers entered the error state. Save your work now!'

I tried setting project option | debugging | type of debugging to
'automatic', 'dwarf with sets', and 'dwarf2'. I get the same debugger
message with each.

I tried turning 'use app bundle for running and debugging' in the project
options on and off. I get the same debugger message.

In IDE debugger options I tried changing EncodeCurrentDirPath from
gdfeDefault to gdfeNone.I get the same debugger message.

When I go to project options and create build modes linking takes 2 minutes
to complete. In the end I still get the same debugger message.

Switching back to my default build mode, when I turn on the project
debugging option 'use external debug symbols file (-Xg)' linking takes 2
minutes to complete each time I hit run. I still get the same debugger

On Wed, Oct 30, 2013 at 5:29 AM, Martin <lazarus at mfriebe.de> wrote:

>  On 30/10/2013 09:28, Martin wrote:
> On 30/10/2013 01:56, Anthony Walter wrote:
>  Problem 2
> --------------
>  http://cache.codebot.org/development/lazarus-run-error.png
>  When I try to run a program (either in debug mode or release mode which
> has no debugging on) I get that message from OS X. It seems to build fine.
> I mentioned above the debugger was gotten from macports and is named ggdb
> on disk rather than gdb and is at version 7.6, if that's important.
>  It is located on my system at
> /opt/local/bin/ggdb
>  I'd very much appreciate it if anyone could help me setup correctly
> working near trunk versions of fpc and lazarus on OS X.
>  And probably need to set debug type info to dwarf (but you have to try
> what works for you (project options > debugger)
> --
> _______________________________________________
> Lazarus mailing list
> Lazarus at lists.lazarus.freepascal.org
> http://lists.lazarus.freepascal.org/mailman/listinfo/lazarus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20131030/72ce7790/attachment-0003.html>

More information about the Lazarus mailing list