[Lazarus] Help: OS X Problems

Martin lazarus at mfriebe.de
Wed Oct 30 14:36:45 CET 2013

On 30/10/2013 12:50, Anthony Walter wrote:
> Earlier (after my initial post) I had found and read the same links 
> you posted. It feels god knowing I am on the right track, so thanks, 
> thigh I am still having problems.
> Where I'm At
> -----------------
> The lazarus revision 43255 you posted locks up at start due to the 
> focus I mentioned previously.
> I deleted my lazarus folder, checked out revision 42619 again, built 
> and run and the IDE opens correctly again. I am using ggdb from 
> macports as mentioned earlier.
> In a new project called 'hello' I set the run host application to 
> /Users/MyUser/Development/Projects/hello.app/Contents/MacOS/hello
> When I run I get a window titled 'Debugger Error' with the text 
> 'Debugger error. Ooops, the debuggers entered the error state. Save 
> your work now!'
> I tried setting project option | debugging | type of debugging to 
> 'automatic', 'dwarf with sets', and 'dwarf2'. I get the same debugger 
> message with each.
> I tried turning 'use app bundle for running and debugging' in the 
> project options on and off. I get the same debugger message.
> In IDE debugger options I tried changing EncodeCurrentDirPath from 
> gdfeDefault to gdfeNone.I get the same debugger message.
> When I go to project options and create build modes linking takes 2 
> minutes to complete. In the end I still get the same debugger message.
> Switching back to my default build mode, when I turn on the project 
> debugging option 'use external debug symbols file (-Xg)' linking takes 
> 2 minutes to complete each time I hit run. I still get the same 
> debugger message.

Did you try the path in "run param" (to the exe  inside the app bundle)?

Unless you upgrade (wich I understand you currently can not) you need AT 
LEAST all of the following 3
1) path in "run param" to the exe  inside the app bundle
2) ExeEncoding
3) |EncodeCurrentDirPath |

***** CORRECTION ***

In my previous post:
> |    EncodeCurrentDirPath = gdfeDefault|

Which is the setting it already has.
It must be changed to |gdfeNone   for BOTH

If nothing helps, please provide a log:

That will allow me to see where exactly the debugger fails.

If the log is bigger, you may send it directly to my mail, bypassing the 

About the none debugger issues (focus...), I have no idea. Someone else 
will need to comment on them.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.lazarus-ide.org/pipermail/lazarus/attachments/20131030/00ec7504/attachment-0003.html>

More information about the Lazarus mailing list