[Lazarus] [ANN] Lazarus Manager v0.8

Hans-Peter Diettrich DrDiettrich1 at aol.com
Fri Jan 10 21:44:54 CET 2014

Kjow schrieb:
> wow, a lot of stuff!
> 2014/1/10 Hans-Peter Diettrich <DrDiettrich1 at aol.com 
> <mailto:DrDiettrich1 at aol.com>>
>     On Win8-64
>     ----------
>     First problem: the edit box for the root directory shows strange
>     behaviour. Inserting characters *into* text can make the cursor jump
>     to the end of the text.
> This is a bug... in path can't be used spaces or special char and it 
> doesn't reposition the cursor at the right place :)

No special characters, I only tried to insert 'LazMgr\' in front of the 
suggested directory. It may be a timing problem, the 'a' or 'z' caused 
the jump to the end of the text.

>     I'm missing an button for executing the Pre-Installation. "Start
>     Necessaries Download" doesn't react, the "FirstInstall" button is
>     far away.

> mmhh... it use generic svn command line program, so if you type "svn" in 
> a new "command prompt" window it should work also on Lazarus Manager...

So it seems to me that TortoiseSVN doesn't install the standard svn.exe. 
Dunno how they make "svn" known to their bash shell.

>     fpcup had other problems, couldn't make it work either.
> I don't know how fpcup works, but if both aren't working it should be a 
> system problem... I don't know... I'll try with an other PC (win8.1 x64).

I use Win8 (NOT 8.1!) only if necessary or simple, otherwise XP (VM) is 
more tansparent and usable for me. Had to disable automatic updates on 
Win8 a long time ago, because it broke several apps; this may be the 
reason why I couldn't (and don't want any more) to upgrade to 8.1. Never 
change a working Windows ;-)

>     Second try in WinXP-32 VM
>     -------------------------
>     SVN can be started in a console, seems to be installed already.
>     Downloads seem to succeed.
>     Error: Binutils directory is empty.
>     Maybe .lzma and .tar are not supported? --> installed 7zip and zlib.
> Lazarus Manager can't manage lzma (or tar), I show a pop-up when 
> required (and I add an advice on log) that this step should be done 
> manually.

*Manually* here means using some tool - which one?

>     Now a couple of consoles seem to checkout the repositories.
>     All done - what now?
>     Try close a console: "Windows cannot cannot close this program"
> Well, the procedure should follow a defined path. If there isn't 
> binutils into the directory everything after the check doesn't work. Of 
> course, there are controls about not proceeding if binutils aren't 
> found, I don't know why in your system this doesn't work... strange.

Would it be simpler to disable "single click installation" in case of 
trouble, and proceed step by step? (should be documented as well)

>     Try "Update", more consoles open *and* close (rapidly, empty?)!
>     These seem to be the "make" consoles?
>     Error: Failed to execute: 2.
>     Huh? config: Drive=2 ?
> Update works only if first installation was ok, so something not defined 
> is happened (and binutils are absolutely required).

When I found the target directories missing, I tried to repeat 
"FirstInstall" (no improvment). How do I a clean restart?

> This log is not so smart :-p
> It just writes what is processing and when it ends, but it doesn't tell 
> (yet?) if all is gone right. Anyway, if in Lazarus (branch/trunk) there 
> are exe files all is gone right :)

Can the "make" consoles be kept open in case of errors (ErrorLevel?), 
for inspection of eventual error messages? Then close after prompting 
the user...

> I don't really know... it seems like there is some interference with 
> other installation/something else, but Lazarus Manager should not care...

Please clarify: is the "temporary" path (shown in the log) the full path 
used during the build process? Which other "standard" directories are 

How is the \pp directory involved? It was created by another Lazarus 
(older, stable) installation, obviously incompatible with the 
current/trunk projects.

A general note on FPC/Lazarus installation:
I had several installations on my old (Win7) system, but don't remember 
how I made "make" work there, and which one was the most recent one. Is 
there something simpler than the BuildFAQ, telling how to make things 
work without killing other existing installations?

As a normal user I'm happy with a single installation, but when I now 
want to explore the new AnsiStrings, I need multiple independent 
installations of FPC (and Lazarus?).

E.g. on Win7 I had an \fpc directory, containing various FPC 
installations, so that I know where to install and find some specific 
compiler. A single (unversioned) \pp directory is not so useful. In 
detail I don't remember which config files/directories belong to which 

I also considered to have different users for each branch, but AFAIR 
this also didn't allow to isolate the installations sufficiently. Would 
this be easier on Linux? [I doubt that, when \lib and other shared 
directories or links are used] Also my Ubuntu VM recently stopped 
working, after an update, with an irrecoverably broken package 
management, unusable for testing.


More information about the Lazarus mailing list