[Lazarus] RC1 Debugger error

JuuS JuuS at mykolab.ch
Thu Feb 19 10:29:53 CET 2015

On 02/18/2015 10:45 PM, Martin Frb wrote:
> Have you checked, if in the new published project debugging is set up ?
> Project options > debugger.
> Is the checkbox set?
> Which debug info is chosen? Dwarf or Stabs? (And what happens if you use
> the other)?
> If all that is set correct, then can you please attach a log, as
> describe here:
> http://wiki.lazarus.freepascal.org/GDB_Debugger_Tips#Log_info_for_debug_session

Debugging option was set to automatic. Both programs had exactly the
same settings in compiler options and debugging options.

One new result as well. To compare debugger options I opened the
origProject, then opened the publProject, then re-opened the
origProject. For fun, I compiled and tried to run...but got the debugger
error...this made me think it was related to simply switching projects?

In any case, I shut down laz, opened the publProject and tried each
debugging option in turn, all resulted in debugging error with the
further result that the last option (Dwarf3) resulted in a compilation
error. All it said was Error: Error while linking.

I set option back to automatic, and shut down laz.

I then ran laz through command line with LOG file to be written, as
shown in the link you gave me.

And.......it ran perfectly no problems, no errors.

I've not attached the log imagining it will not help you in this case?

Also, the log file is quite large, appending it here would be over the
list email size limit I think. How is that usually done then? Upload to
a web site and then simply provide a link?

Any way let me know if I can provide anything else, or if you would like
the resulting log file...

More information about the Lazarus mailing list