[Lazarus] CodeToolManager: file was not reached by scanner

Valdas Jankūnas zmuogs at gmail.com
Fri Feb 27 23:59:17 CET 2015


  I managed to fix that problem but in unexplainable manner:

2015.02.27 18:03, Mattias Gaertner rašė:
> It means codetools parsed the unit, but the parser didn't come to the
> position, where the cursor is. For example if there is an "end." in
> front. Search for the "end."
> You can find out in "Code Explorer" what the parser found.

I checked all "end.", it appears only in ".pas" files, only once in 
every file.

> Another possibility is that irankiai.pas is/was an include file.
> Open irankiai.pas, then IDE menu / Source / View Unit information /
> clear include cache.

  Unit Information shows that unit "irankiai.pas" is included by main 
unit "pagrindinis.pas". If I press "Goto Include Directive" then cursor 
jumps at line "unit pagrindinis;" in main unit and message window shows 
same error.
  I tried to clear include cache - it help little: I can Ctrl+Up,Down in 
"irankiai.pas". But if I in another unit do Ctrl+LeftMause on function 
name which is implemented in unit "irankiai.pas"  then problem arises.
  Unit "irankai" is in Uses clause in implementation section in main 
unit, so I moved that unit usage in interface section - that helped. And 
then again, restored it in to implementation section - no problems. Strange.

   Valdas Jankūnas

More information about the Lazarus mailing list