[Lazarus] CodeToolManager: file was not reached by scanner

Mattias Gaertner nc-gaertnma at netcologne.de
Sat Feb 28 00:18:27 CET 2015


On Sat, 28 Feb 2015 00:59:17 +0200
Valdas Jank┼źnas <zmuogs at gmail.com> wrote:

>[...]
> > Another possibility is that irankiai.pas is/was an include file.
> > Open irankiai.pas, then IDE menu / Source / View Unit information /
> > clear include cache.
> 
>   Unit Information shows that unit "irankiai.pas" is included by main 
> unit "pagrindinis.pas". If I press "Goto Include Directive" then cursor 
> jumps at line "unit pagrindinis;" in main unit and message window shows 
> same error.
>   I tried to clear include cache - it help little: I can Ctrl+Up,Down in 
> "irankiai.pas". But if I in another unit do Ctrl+LeftMause on function 
> name which is implemented in unit "irankiai.pas"  then problem arises.
>   Unit "irankai" is in Uses clause in implementation section in main 
> unit, so I moved that unit usage in interface section - that helped. And 
> then again, restored it in to implementation section - no problems. Strange.

Can you reproduce the problem when moving the "uses" back to
implementation?

Mattias




More information about the Lazarus mailing list