[Lazarus] Newbie, porting class to FPC but get procedure assignment error

Bo Berglund bo.berglund at gmail.com
Mon Jun 22 14:51:11 CEST 2015

On Mon, 22 Jun 2015 12:39:18 +0200, Giuliano Colla
<giuliano.colla at fastwebnet.it> wrote:

>Both Win32 and Win64 generate the same compiler option(-WG)
>In the same configuration page you should also pick up the right Target 
>CPU family: i386 as opposed to X86_64, in order to generate a 32bit 
>application. This will require the proper 32 bit compiler. If it isn't 
>available or properly configurated you'll get a warning, when you click 
>the Test button on the page.

I found these additional settings and set as follows:
Target OS: Win32
Target CPU family: i386
Target processor: Default
Win32 gui application: checked

When I used the Test button I got this:

HINT: using config file
WARNING: ppu exists twice:
WARNING: ppu exists twice:

I don't know/understand why the latter ppu warnings are shown...

When I run with these new settings I get the exact same error at the
exact same place as before.

Bo Berglund
Developer in Sweden

More information about the Lazarus mailing list