[Lazarus] Newbie, porting class to FPC but get procedure assignment error

patspiper patspiper at gmail.com
Mon Jun 22 16:01:45 CEST 2015

On 22/06/15 15:51, Bo Berglund wrote:
> On Mon, 22 Jun 2015 12:39:18 +0200, Giuliano Colla
> <giuliano.colla at fastwebnet.it> wrote:
>> Both Win32 and Win64 generate the same compiler option(-WG)
>> In the same configuration page you should also pick up the right Target
>> CPU family: i386 as opposed to X86_64, in order to generate a 32bit
>> application. This will require the proper 32 bit compiler. If it isn't
>> available or properly configurated you'll get a warning, when you click
>> the Test button on the page.
> Thanks:
> I found these additional settings and set as follows:
> Target OS: Win32
> Target CPU family: i386
> Target processor: Default
> Win32 gui application: checked
> When I used the Test button I got this:
> HINT: using config file
> C:\programs\lazarus\fpc\2.6.4\bin\i386-win32\fpc.cfg
> WARNING: ppu exists twice:
> C:\programs\lazarus\fpc\2.6.4\units\i386-win32\fv\dialogs.ppu,
> C:\programs\lazarus\lcl\units\i386-win32\dialogs.ppu
> WARNING: ppu exists twice:
> C:\programs\lazarus\fpc\2.6.4\units\i386-win32\fv\menus.ppu,
> C:\programs\lazarus\lcl\units\i386-win32\menus.ppu
> I don't know/understand why the latter ppu warnings are shown...
IIRC, these 2 specific warnings are benign.
> When I run with these new settings I get the exact same error at the
> exact same place as before.

Check the bitness of the produced executable.


More information about the Lazarus mailing list