[Lazarus] How to get Lazarus on Odroid U3 with Ubuntu 14.04 to work ?

Corpsman corpsman at web.de
Thu Mar 12 08:23:43 CET 2015


Hello Mailinglist,

Is there someone who got lazarus (doesn't matter which version) to work
under Ubuntu 14.04 on a Odroid U3 ?

I tried this in several ways, unfortunatunelly without success. The core
problem seems to be in the GTK2 api (i don't need especially gtk2 but qt
did not work as well).

i try :
Installing a fresh 14.04 Image, using the lazarus fpc from the packet
manager -> all icons in the ide are broken (invisible) if the ide is
started from a console it writes something like "try to write 24-bit on
a 32-bit canvas..)

i try :
Update from 13.04 (with working fpc 2.6.2 and lazarus from trunk), after
update to 14.04 same behavier as above.

i try :
fpcup (and did what the warning tells), the fpc installation runs
through, the compilation of the ide runs the first time, the second run
(to install anchordicking, fails). Using the binary from the first run
has the same behavior as in the following buglist ticket.

a lot of research got me

- A Buglist ticket : http://bugs.freepascal.org/view.php?id=26726
  |-> unfortunatunelly it seems that no one of the core developer has a
odriod so that they can fix it

- the fpcup skript (that did not work) from
http://wiki.freepascal.org/Odroid

- also i tried different forums, but no one could help me

[german] http://www.lazarusforum.de/viewtopic.php?f=3&t=8537 [^]

[german] http://www.lazarusforum.de/viewtopic.php?f=5&t=8456 [^]

[english] http://forum.odroid.com/viewtopic.php?f=77&t=10840 [^]

- the download link of the Ubuntu 14.04 1 / 2 images for odroid

http://odroid.com/dokuwiki/doku.php?id=en:u3_ubuntu_release_note_20150224


At the moment i run 13.10 on my Odroid U3, with Lazarus trunk and fpc
from the packet center. But 13.10 gets more and more in trouble. I use
the Odroid as my Desktop PC so there is a big need to move to the LTS
version.

it would be very nice if someone could help me.

Uwe Sch├Ąchterle





More information about the Lazarus mailing list